General Help


General Help

Omnia Creator

Help Index

Omnia Creator is new software. Please report any issues at: Omnia Creator’s GitHub. Please see the Forums for online Help Support.


Getting Started Help

Thank you for downloading Omnia Creator! Before getting started with Omnia Creator there are a few things you should know about it:

  • Omnia Creator is a project based IDE in contrast to Arduino like IDEs which are file based IDEs. File based IDEs build and run whatever the current open file is. The Arduino IDE, for example, builds and runs whatever INO main file (sketch) you have open. File based IDEs are easier to use than project based IDEs for simple projects that only consist of one file. However, once you start having to deal with multiple files per project and more complex code structures you need a project based IDE like Omnia Creator. A project based IDE builds and runs whatever file or folder of code you set as the project. By allowing the current file being edited to be separate from the project you can work on and cross reference a lot of different code from multiple projects without having to worry about the project changing on you when you switch files.
  • Omnia Creator uses a CMake/Ninja backend to build and run your code. CMake is a cross platform build system which is controllable through user editable CMake scripts. Omnia Creator comes with CMake scripts for building your code on microcontrollers boards like the Arduino by default. If you want to add support for other microcontrollers boards you can easily by writing the necessary CMake scripts to support them. With Omnia Creator you can now develop all of your code in one IDE.
How to make a new file or project

To make a new file or project go to the main Omnia Creator window, open the File Menu and click New File or Project…. A dialog box will appear giving you the following options:

New File Or Project Dialog

  • New File
    • The New File option just makes a new text or binary file with Omnia Creator. This option does not alter the current project in any way. Omnia Creator will automatically create known C/C++/etc. file types with a basic header that includes your user name and the current date/time.
  • New Project in Folder
    • The New Project in Folder option makes a new folder with an optional C main file and header, C++ main file and header, or INO main file (sketch) with Omnia Creator and sets the current project to that folder. After which, Omnia Creator will setup the CMake build system for whatever Board Type you have selected. Omnia Creator will watch your project folder for any changes to keep the CMake build system up to date if you add/remove/rename any files/folders. Once you’ve selected a Project File and Board Type the Build and Run buttons should be active.
      • TIP: If you have any issues with Omnia Creator’s project system not working when you change the current project try changing the board type to something else and then back. This should fix any glitches until all the bugs in Omnia Creator are ironed out.

New Project Folder Dialog

  • New File Based Project
    • The New File Based Project option makes a new text or binary file with Omnia Creator and sets the current project to that file. After which, Omnia Creator will setup the CMake build system for whatever Board Type you have selected. Once you’ve selected a Project File and Board Type the Build and Run buttons should be active. Omnia Creator will automatically create known C/C++/etc. file types with a basic header that includes your user name and the current date/time.
      • TIP: If you have any issues with Omnia Creator’s project system not working when you change the current project try changing the board type to something else and then back. This should fix any glitches until all the bugs in Omnia Creator are ironed out.

New Project File Dialog

How to open a file or project

To open a file or project go to the main Omnia Creator window, open the File Menu and click Open File or Project. A dialog box will appear giving you the following options:

Open File or Project Dialog

  • Open File
    • The Open File option just opens a text or binary file with Omnia Creator. This option does not alter the current project in any way.
  • Open Project in Folder
    • The Open Project in Folder option opens all the files with the same base name as the folder you select in the folder you select with Omnia Creator and sets the current project to the folder. After which, Omnia Creator will setup the CMake build system for whatever Board Type you have selected. Omnia Creator will watch your project folder for any changes to keep the CMake build system up to date if you add/remove/rename any files/folders. Once you’ve selected a Project Folder and Board Type the Build and Run buttons should be active.
      • TIP: If you have any issues with Omnia Creator’s project system not working when you change the current project try changing the board type to something else and then back. This should fix any glitches until all the bugs in Omnia Creator are ironed out.
  • Open File Based Project
    • The Open File Based Project option opens the selected file with Omnia Creator and sets the current project to that file. After which, Omnia Creator will setup the CMake build system for whatever Board Type you have selected. Once you’ve selected a Project File and Board Type the Build and Run buttons should be active.
      • TIP: If you have any issues with Omnia Creator’s project system not working when you change the current project try changing the board type to something else and then back. This should fix any glitches until all the bugs in Omnia Creator are ironed out.
How to build a project

After you’ve created/opened a project and selected a Board Type from the Board Menu the Build button should become active. Click the Build button to build the project. If there are any errors in your code Omnia Creator will highlight the line on which the error occurs. Warnings will also be highlighted. For convenience, all errors and warning are collected and shown to you after building your code in in the Issues view (on the status bar). Clicking on an issue in the Issues view will take you to the file and line number of the issue. If you want to see the compile output click on the Compile Output view (on the status bar). In the Compile Output view you can see exactly how Omnia Creator builds all of your code.

When you first click Build for a project/board/serial port combo that you’ve never built before Omnia Creator needs to re-build all the source files associated for your project and cache them in your Temp directory. After the initial build Omnia Creator only needs to rebuild any sources that you change. Feel free to close and re-open Omnia Creator, it will remember what needs to be re-built. In the future, Omnia Creator will permanently cache library files for all board types so that when you don’t have to constantly rebuild and cache your library build files for each project/serial port combo.

How to run a project

After you’ve created/opened a project and selected a Board Type and Serial Port from the Board Menu the Run button should become active. Click the Run button to build the project and then load your code onto your microcontroller attached to the Serial Port. If there are any errors in your code Omnia Creator will highlight the line on which the error occurs. Warnings will also be highlighted. For convenience, all errors and warning are collected and shown to you after building your code in in the Issues view (on the status bar). Clicking on an issue in the Issues view will take you to the file and line number of the issue. If you want to see the compile output click on the Compile Output view (on the status bar). In the Compile Output view you can see exactly how Omnia Creator builds all of your code.

When you first click Run for a project/board/serial port combo that you’ve never built before Omnia Creator needs to re-build all the source files associated for your project and cache them in your Temp directory. After the initial build Omnia Creator only needs to rebuild any sources that you change. Feel free to close and re-open Omnia Creator, it will remember what needs to be re-built. In the future, Omnia Creator will permanently cache library files for all board types so that when you don’t have to constantly rebuild and cache your library build files for each project/serial port combo.


User Interface Help

Omnia Creator is a streamlined version of Qt Creator for Makers that exposes some, but not all, of Qt Creator’s features. For code editing help please see the Editor Help page. For Board Menu and Widgets Menu help please see below.


Board Menu Help

The Board Menu contains functions for controlling the Serial Port and Board Type.

How to change a serial port board name

Omnia Creator allows you change your serial port’s name. Go to the Board Menu and click Change Serial Port Board Name to change your serial port’s name.

Change Board Name Dialog

How to change a serial port board type

Omnia Creator allows you change your serial port’s board type. Go to the Board Menu and click Change Serial Port Board Type to change your serial port’s board type.

Change Board Type Dialog

How to change the serial port

Go to the Board Menu and click Serial Port and select the serial port you want to change to.

How to change the serial port baud rate

Go to the Board Menu and click Baud Rate and select the baud rate you want to change to. Note: The Omnia Creator Serial interface Library only works with the Auto baud rate.

How to reset the Serial Port

To reset the serial port state machine go to the main Omnia Creator window, open the Board Menu and click Reset Serial Port. You may need to reset the serial port state machine if it gets out of sync with the byte streaming coming from your microcontroller.


Widgets Menu Help

The Widgets Menu contains functions for controlling Omnia Creator Widget Windows. Controls for showing or hiding Widget Windows will appear in this menu. You can show or hide the default serial terminal by clicking Serial Terminal in this menu.

How to Show All Widgets

Go to the Widgets Menu and click Show All Widgets.

How to Hide All Widgets

Go to the Widgets Menu and click Hide All Widgets.

How to export a widget’s state

Go to the Widgets Menu and select a widget from the Export Widget State menu.

How to import a widget’s state

Go to the Widgets Menu and click Import Widget State.

How to remove a widget

Go to the Widgets Menu and select a widget from the Remove Widget menu. Note: Removing a widget which is currently receiving data will cause Omnia Creator to print warning messages to the General Messages output view.

How to remove all widgets

Go to the Widgets Menu and click Remove All Widgets. Note: Removing a widget which is currently receiving data will cause Omnia Creator to print warning messages to the General Messages output view.

How to reset the Serial Terminal

To reset the serial terminal state machine go to the main Omnia Creator window, open the Widgets Menu and click Reset Serial Terminal. You may need to reset the serial terminal state machine if it gets out of sync with the byte streaming coming from your microcontroller. Resetting the serial terminal’s state machine clears the default serial terminal’s screen and resets the new text color to black.